Pinpoint is experiencing degraded performance

Incident Report for UMD Engineering IT

Resolved

Mitigations have been deployed to address the issues we are experiencing with the upstream provider.
Posted Apr 21, 2026 - 18:25 EDT

Update

A workaround is being implemented to handle new limits from Parchment Digital Badges.
Posted Apr 21, 2026 - 14:52 EDT

Monitoring

Pinpoint is currently experiencing degraded performance due to issues with an upstream provider. We are working with the provider to address the cause.
Posted Apr 20, 2026 - 17:47 EDT
This incident affected: Specialized Services (Pinpoint Makerspace Management System).