Campus-wide power outage affecting IT services

Incident Report for UMD Engineering IT

Resolved

This incident has been resolved.
Posted Sep 02, 2025 - 12:50 EDT

Monitoring

All IT services have been restored and are operating normally. We will continue to monitor into the night for any issues prior to closing this incident.
Posted Aug 29, 2025 - 19:30 EDT

Update

Power has been restored to the majority of campus. Engineers are working to restore affected IT services now.
Posted Aug 29, 2025 - 17:46 EDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 29, 2025 - 17:21 EDT

Identified

An issue with the campus electrical system near the Research Greenhouse complex was determined to have caused the outage. Facilities Management crews have begun restoration work and anticipate an ETA of 5:00 PM - 6:00 PM EDT for restoration of power. Buildings close to the Research Greenhouse complex may take longer to restore.
Posted Aug 29, 2025 - 14:36 EDT

Update

Impacts to additional services have been updated.
Posted Aug 29, 2025 - 14:15 EDT

Update

All EIT-supported Drupal websites are currently affected by this outage.
Posted Aug 29, 2025 - 13:34 EDT

Investigating

A campus-wide power outage is affecting some IT services. We will provide updates as we receive them from Facilities Management and Division of IT.
Posted Aug 29, 2025 - 13:26 EDT
This incident affected: Email, Communication, & Collaboration (Engineering Websites), Networking & Connectivity (Wireless Network (eduroam, umd-iot, umd-guest), Wired Network), Printing Services (WEPA Print Stations), and Room Reservations & Scheduling (Robin Displays (Room iPads)).