Engineering websites are experiencing issues

Incident Report for UMD Engineering IT

Resolved

This incident has been resolved.
Posted May 06, 2026 - 12:20 EDT

Monitoring

Mitigations have been applied & websites are now functioning normally. We will continue to monitor for the next several hours.
Posted May 06, 2026 - 11:26 EDT

Identified

A sustained scan by several botnets has amounted to a denial of service attack on our website infrastructure. Engineers are applying mitigations.
Posted May 06, 2026 - 10:42 EDT

Investigating

Engineering websites are experiencing issues. We are looking into the problem.
Posted May 06, 2026 - 10:12 EDT
This incident affected: Email, Communication, & Collaboration (Engineering Websites).